Technical Requirements

« Back  |  

What are the minimum system requirements?
The Learning Cloud was built and optimized for desktops and laptops running Windows, MacOS, and Chrome OS. Additional requirements are as follows:

  • Hardware: Desktop, Laptop, or Chromebook.
  • Supported Operating Systems: Windows 10 and higher. MacOS 10.10 and higher. ChromeOS.
  • Supported Browsers: Chrome, Edge, Safari.
  • Minimum Resolution: 1024×768.
  • Audio Output device. Example: Speakers.
  • Stable internet connection, downstream speeds at least 10mbps.
  • Mouse or Trackpad.
  • Full QWERTY Keyboard.

Note: for the best experience, and to ensure compatibility, the latest OS and browser updates are recommended. Touch Screen mobile devices such as an iPad or a mobile phone are not recommended.

The following items are suggested for all courses:

  • Earbuds
  • Webcam
  • Printout of course pace chart and syllabus
  • Calendar/planner
  • Pencils and college ruled paper for students who would like to take written notes

There are a few materials and downloads needed for particular courses (mainly electives) and a tech and materials spec document can be requested for any course.

Devices (We recommend devices less than 5 years old)

  • Desktop
  • Laptop
  • Chromebook
  • Microphone and webcam

Operating Systems

  • Windows 10 and newer
  • Mac OSX 10.6 and newer
  • Linux
  • ChromeOS

Internet Speed

  • High speed internet (recommended)

Supported Browsers

  • Edge (latest version)
  • Safari (latest version)
  • Chrome (latest version)
  • Firefox (latest version)

Supported Browser Plugins and Settings

  • Javascript enabled
  • Flash – latest version is recommended
  • 1024×768 is recommended
  • Pop-up blockers should be disabled
  • Cookies should be enabled.

Virtual Reality (VR) /Augmented Reality (AR) Some courses have Virtual and Augmented Reality experiences which are best viewed with devices that are AR/VR enabled. These experiences can have large file sizes and it is recommended that they are downloaded over wi-fi. Minimum Devices:

  • iPhones 5S
  • Samsung Galaxy S5
  • Newer VR/AR enabled devices (Recommended)

Please contact support.asuprep.org for further assistance.